greyed out options under tools menu

Oct 13, 2010 at 8:14 AM

No matter what pdf file I use, under the tools menu all options are greyed out, except for 'merge documents' and 'security'.

Unfortunately no help information is available for PDF Rider (ver. 0.4), so hopefully someone can shine a light on this issue?

When are the insert/extract/delete/... options disabled?

Coordinator
Oct 13, 2010 at 2:27 PM

When "Tools" menu items are grayed out, you should see an information bar with the following message: "Cannot retrieve informations about the document. The document could be an invalid pdf document or password protected." This occurs when PDFRider cannot retrieve necessary informations from the document. This is due to an invalid pdf or if the pdf is password protected (that is why "Security" menu item is still enabled).

If you are using Windows 7, there are some compatibilty problems between this os and the component responsable to get the information from the document (aka pdftk), as discussed here.

I have tried on my pc (with Windows 7) and after opening the document twice, it worked fine.

I have no more informations at the moment. Sorry.

Oct 14, 2010 at 8:43 AM

I got it working, thanks.

Seems that I get the options greyed out when I drag a document from explorer onto the PDFRider app (no matter how many times I do this).

When I open the document from the PDFRider 'application' menu / 'open document', these options are all available.

 

Coordinator
Oct 15, 2010 at 9:01 AM

I didn't think about the drag and drop option and, of course, it doesn't work. Maybe I can implement it. Thanks for the point!

You can also open the documents from explorer by setting PDFRider as the default pdf application, or via "Open with" command.

Aug 24, 2011 at 3:16 PM

I had the same problem with "Cannot retrieve informations..." no matter how many times and different ways I tried opening it.

I then tried to change the name of the pdf to "hulabula" just to be sure, and then i suddenly worked. Dunno if it was because of a "space" in the name or something, but i worked.

Btw, thank you for a wonderfull program.

Coordinator
Aug 25, 2011 at 3:20 PM

Thanks for the post.

I did a little search and I found that this problem is relative to the file path, which must not contain "special" characters (for "special" I mean all those characters from code 128 to 255 of ASCII table, and non printable characters - view ascii table - )

This is actually an annoying bug, but I have no intentions to fix it at the moment...

May 28, 2013 at 12:54 PM
Perdón por expresarme en español.

Yo he comprobado que al ejecutar PDF Rider sin permisos de Administrador ocurre el problema con los ficheros Pdf.
Cuando abro el programa como Adminstrador puede fallar alguna vez pero en general funciona OK.
Dec 7, 2014 at 3:50 AM
Edited Dec 7, 2014 at 3:57 AM
I had the same issue in windows 8.1 and was able to resolve it by following these suggestions:
  1. open the pdf rider application with administrator permissions
  2. make sure pdf file has no spaces or symbols.
  3. open file from within pdf rider
    It worked for me in windows 8.1 with the surface pro 3
En español
Tenia el mismo problema en windows 8.1 y pude resolverlo siguiendo estas sugerencias:
  1. Abrir el programa "pdf rider" con permisos de administrador.
  2. Asegurar que el archivo pdf no tenga espacios o simbolos.
  3. Abrir el archivo pdf desde adentro del programa de pdf rider.
    Funciono en windows 8.1 usando el surface pro 3
Nov 19, 2015 at 6:22 PM
I would really appreciate it if you did fix this, as the program is almost useless with this bug in place.
Nov 14, 2016 at 2:22 PM
Edited Nov 15, 2016 at 9:51 AM
I've found an odd work around (for the end user).

For us it doesn't show an information bar, so may be separate.

The first time I open the file the options are greyed out. If I drag the same file over (so it hides the preview) and move it out and then back in again... it opens and the options are no longer greyed out. It seems if you move it in fast the programme does not get to detect the drag over event handler to hide the browser view... and once over the browser the software cannot detect a drag/drop (which is why its hidden).

EDIT: Actually, you can get it to work the first time, since when its first open the browser object is there showing an empty page - if you drag over slowly so your file is over the border for X amount of time, then into the main window - there is enough time for the programme to capture the drag event to hide it. Instead most people are dragging it directly into the browser object and the browser itself is opening the document so no process in the software is run to enable the burst commands etc.

Why it doesn't open the first time I cannot tell yet, even looking a the source.

This problem has occured even under an admin account, on files with no special characters or spaces so may be separate to the above. I will be looking and hopefully finding the code to sort this after ive seen another patch possibly committed.
Dec 1, 2016 at 11:30 AM
Another reason for this may be because the user does not have permissions to modify the program files folder, this shouldn't be done.

You can give your users modify access to "fix" this.