This project is read-only.

Won't Open File

Nov 1, 2010 at 3:44 PM

When I try to open a PDF file, dialog opens "File Download - Do you want to save this file or find a program on line to open it?".

Using Windows 7.



Nov 2, 2010 at 8:46 AM

You need a separate pdf reader that can be opened inside Internet Explorer.

If you are using Adobe Reader make sure you have the correct version for the browser (For IE8 it sould be version 9.3 or higher).

Apr 4, 2011 at 8:52 PM


I have Adobe Reader X and I know the browser plugin works. I've tried to open my PDF-file with IE, works just fine.

However, I get the same result as tcarnevale when I try to open it with PDF Rider.


I have Chromium as standard browser. But I did change it back to IE once to see if that was the issue.

Apr 8, 2011 at 6:56 PM

I had the same problem when i try to run it on Windows 7 64-bit. It appears it runs in 64-bit mode and invokes the WebBrowserUtility control in 64-bit mode (IE 64-bit?) as well. As there is no 64-bit Adobe Reader installed, it gives the option to open or save the PDF file. I recompiled the code to target x86 platform only, and i am able to run it successfully on my windows 7 64-bit machine.

May 17, 2011 at 3:41 PM

I use Firefox and Foxit. This used to werk superbly under Xp.

Now in Windows 7 I seem to have an issue.

When I open pdf rider, it also asks me if I want to open or download.

Then the pdf is opened in foxit.  So at that moment I have two windows: a blank one of PDF rider, and a Foxit window with the pdf diplayed. When I try an operation in Pdf rider, however, it does perform the operation (like burst). So it works, but you cannot see what you are doing, unless you switch between windows, that is.

Same when I uninstalled firefox (i.e. under IE).

May 18, 2011 at 7:50 PM

So, I solved it.

I remember that under xp it wouldn't also work when I first started, because of a .net issue.

So I first looked in the software overview, saw that .net 4.0 was installed. PDF rider needs 3.5 as far as I remember. Some googleing shows it should be part of Windows 7 though.

So I went to the configuration screen again to the enable / disable windows functions section. Microsoft .NET 3.5.1. is ticked but grey. If you open it, and tick both Windows Communication Foundation HTTP Activation and Windows Communication Foundation non-HTTP Activation, it does the trick!